MozillaZine

Whitehart Development [FFX+TB]
Author Message
Aureliano Buendía
Joined: 12 Aug 2006
PostPosted: Apr Fri 13th 2007 7:05am     
DonGato wrote:
That happens when nobody helps with checking the new versions. I don't use that feature so I missed the issue.
Check with interim version 2.0.1.


Now work fine.
Thanks.

Ciao.
[Profile] [Pri. Msg.] [Quote]
flaxthejute
Joined: 16 Nov 2003
Dundee, Scotland
PostPosted: Apr Fri 20th 2007 5:24am     
Hi,

Just discovered this theme for Thunderbird 2.0, it fits beautifully with the minimal themes I like to use for other applications. But (and I know that this is a bit cheeky) is possible to add icons for the Buttons! add-on? I noticed that you indulged somebody earlier with an icon for Redirect.)

TIA

Flax
[Profile] [Pri. Msg.] [Quote]
DonGato
Joined: 01 Dec 2005
PostPosted: Apr Fri 20th 2007 6:04am     
I'm sorry but that extension is a mess. They are duplicating Thunderbird buttons so I don't feel like designing special buttons for actions that are already covered in the main client. Some are ok but I won't do a half work for it so I won't add any customization for it.
[Profile] [Pri. Msg.] [Quote]
Aureliano Buendía
Joined: 12 Aug 2006
PostPosted: Apr Fri 20th 2007 10:17am     
Hi DonGato.
Today i installed whitehart 2.1 release. When i check one of new customization property in window addon, dispaly window message "Restart Firefox to activate change" and not "Restart Thunderdird...".
Another (minor) question: the new addon custumization is not localized.

Ciao.
[Profile] [Pri. Msg.] [Quote]
DonGato
Joined: 01 Dec 2005
PostPosted: Apr Fri 20th 2007 10:33am     
1. Thanks, I will fix that. Smile
2. No, I don't believe in localization. Razz
[Profile] [Pri. Msg.] [Quote]
Aureliano Buendía
Joined: 12 Aug 2006
PostPosted: Apr Fri 20th 2007 10:46am     
Ok!
Thanks.
[Profile] [Pri. Msg.] [Quote]
Aureliano Buendía
Joined: 12 Aug 2006
PostPosted: May Wed 16th 2007 10:56pm     
One bug: in the new mail alert window, the close button "X" not is displayed.
See this:

[img=http://img514.imageshack.us/img514/5830/erroremn9.th.jpg]

Ciao.
[Profile] [Pri. Msg.] [Quote]
DonGato
Joined: 01 Dec 2005
PostPosted: Jun Mon 4th 2007 11:36pm     
I should make some time to post an update.
I fixed the issue Icaro, thanks for the report.
[Profile] [Pri. Msg.] [Quote]
Aureliano Buendía
Joined: 12 Aug 2006
PostPosted: Jun Wed 6th 2007 2:35am     
Ok! I hope update coming soon.

1. bug for Firefox theme: when drag 'n' drop an tab, the vertical arrow not is displayed!
2. it is possible to make a divider line from menubar and nav-bar? See this



3. bug in windows add-on (or compliance problem with nightly tester tool extension): see this



Another question: for my opinion the icon of "new tab" not is good as the others... but is my personal opinion! Wink

Thanks.
Ciao.

Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.4) Gecko/20070604 Thunderbird/2.0.0.4 ID:2007060411
Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4 ID:2007051502
[Profile] [Pri. Msg.] [Quote]
DonGato
Joined: 01 Dec 2005
PostPosted: Jun Wed 6th 2007 7:39am     
1. It is shown here. It might be a compatibility problem with one of your extensions. Try to find which one.
2. You're using an extension there that is not using a divider. Add the bookmarks toolbar and you will see how a divider is shown.
3. It seems to me that is a bug in the nightly tester tool extension. I can fix that with a rewrite of their styling code but it would be better for them to fix it. Will check why this happens when I have some time.
4. Well, it's a matter of opinions... I don't see anything wrong with it and I don't have much size to play with.
[Profile] [Pri. Msg.] [Quote]
Aureliano Buendía
Joined: 12 Aug 2006
PostPosted: Jun Wed 6th 2007 8:18am     
Ciao DonGato.

I try with all my Firefox extension disabled and Whitehart theme:

1. the problem it is live: the arrow when drag and drop tab not is dispalyed. With the default theme no problem: see this

[img=http://img444.imageshack.us/img444/6116/immaginevr1.th.jpg]

2. the problem it is live. In my userchrome.css i post this codes for reordering toolbars

#toolbar-bookmark {-moz-box-ordinal-group: 1 !important;}
#nav-bar {-moz-box-ordinal-group: 2 !important;}
#toolbar-menubar {-moz-box-ordinal-group: 3 !important;}

Any idea?

Ciao and thanks.
[Profile] [Pri. Msg.] [Quote]
DonGato
Joined: 01 Dec 2005
PostPosted: Jun Wed 6th 2007 9:49am     
Well, remove that customization and check as I can assure that this is not a broad problem. This theme was done so it integrates with the top part of the browser instead of the bottom as the original. That might introduce some restrictions that you might be triggering by reordering the toolbars.
If it doesn't work test with a clean profile.

[Profile] [Pri. Msg.] [Quote]
Aureliano Buendía
Joined: 12 Aug 2006
PostPosted: Jun Wed 6th 2007 10:22am     
For the problem number 1. from my previous post, i verified that the arrow not is displayed when i check the option "No color icon style" in Whitehart option dialog.

For the problem number 2. i can resolve with this code in my userchrome.css

#toolbar-menubar {-moz-box-ordinal-group: 3 !important;
border-top: 1px solid!important;
}
What it is the color of others borders in your theme?
I set the same border-color property in userchrome.css and the problem it is fixed for me!


Ciao.

Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4 ID:2007051502
[Profile] [Pri. Msg.] [Quote]
DonGato
Joined: 01 Dec 2005
PostPosted: Jun Wed 6th 2007 12:34pm     
1. Ok, found the issue. It seems not much people use the No Color style as the problem was only with this option. Razz
2. rgb(204, 204, 204) or #CCCCCC
3. I checked MR Tech site and that extension you use isn't listed anymore. Wasn't deprecated by another extension like local install? Anyway, I tested this new one and it has a problem with the No Color option as well. Nothing can be done in this case other than using the colored style. I said when I was asked about the no color profile that it was a bad hack.

Current Firefox beta version is 2.4.1.
Current Thunderbird beta version is 2.1.1.
[Profile] [Pri. Msg.] [Quote]
Aureliano Buendía
Joined: 12 Aug 2006
PostPosted: Jun Wed 6th 2007 10:53pm     
Ciao DonGato.

All my posted bugs they are fixed from your last releases (Firefox 2.4.1 and Thunderbird 2.1.1), except the problem with the button of "nightly tester tool" extension when the "no color icon style" it is checked.

For point 2.: i set this color in my userchrome.css and now it is right... Smile see this



Thanks for your work and sorry for my bad english.

Ciao
[Profile] [Pri. Msg.] [Quote]